通达信绝顶指标,通达信主力资金进出指标

Q1:想请绝顶高手把通达信“神奇均线”和“平滑乖离”变成选股公式,如图。先谢谢啦~~

N:=6;
VAR2:=(CLOSE-MA(CLOSE,N))/MA(CLOSE,N)*100;
VAR3:=(EMA(VAR2,3)+EMA(VAR2,6)+EMA(VAR2,12)+EMA(VAR2,24))/4;
A1:= EMA(VAR3,2);
A2:= EMA(A1,2);
A3:= EMA(A2,2);
A4:= EMA(A3,2);
A5:= EMA(A4,2);
A6:= 3*A1-2*A2;
XG:CROSS(A6,A5);
{平滑乖离测试通过! 也可以用 "XG:CROSS(A1,A5);" 替换上面XG:那一行.}
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A8:= EMA(VAR1,2.78)*1.028;
A9:= MA(OPEN,3.2)*1.028;
XG:CROSS(A8,A9);
{神奇均线测度通过!}

Q2:求好心人,帮把通达信指标改成文华财经

这段通达信指标可以修改为文华财经使用效果如下图一张通达信,一张文华财经效果。

Q3:下面这段代码有没有未来函数,是可以在通达信中使用的,公式名称“绝顶”

找出3天前发现150日内的最高价并标明。没用的。

Q4:通达信指标修改

VAR1:=((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15)))*(100);
VAR2:=SMA(VAR1,5,1);
K:SMA(VAR2,3,1),COLORWHITE,NODRAW;
D:SMA(K,3,1),COLORYELLOW,NODRAW;
买入:CROSS(K,D)AND
CLOSE>MA(CLOSE,5),COLORRED,NODRAW;
止盈:CROSS(D,K)AND
MA(CLOSE,5)>CLOSE,COLORGREEN,NODRAW;
连红T:BARSLAST(K<=D),COLORRED,NODRAW;

STICKLINE(K>=D,K,D,3.0,1),COLORRED;
STICKLINE(K<=D,K,D,3.0,1),COLORGREEN;
STICKLINE(CROSS(K,D)AND
CLOSE>MA(CLOSE,5),K,D-5,0.0,0),COLORRED;
STICKLINE(CROSS(D,K)AND
MA(CLOSE,5)>CLOSE,K,D+5,0.0,0),COLORGREEN;
STICKLINE(CROSS(K,D)AND
CLOSE>MA(CLOSE,5),K,D,3.0,0),COLORRED;
STICKLINE(CROSS(D,K)AND
MA(CLOSE,5)>CLOSE,K,D,3.0,0),COLORGREEN;

{STICKLINE(K>=D,K,D,3.0,0),COLOR0000AA;
STICKLINE(K>=D,K,D,2.3,0),COLOR0000BB;
STICKLINE(K>=D,K,D,1.5,0),COLOR0000CC;
STICKLINE(K>=D,K,D,0.8,0),COLOR0000DD;
STICKLINE(K>=D,K,D,0.2,0),COLOR0000EE;
STICKLINE(K>=D,K,D,0.0,0),COLOR0000FF;
STICKLINE(K<=D,K,D,3.0,0),COLOR00AA00;
STICKLINE(K<=D,K,D,2.3,0),COLOR00BB00;
STICKLINE(K<=D,K,D,1.5,0),COLOR00CC00;
STICKLINE(K<=D,K,D,0.8,0),COLOR00DD00;
STICKLINE(K<=D,K,D,0.2,0),COLOR00EE00;
STICKLINE(K<=D,K,D,0.0,0),COLOR00FF00;
DRAWTEXT(CROSS(K,D)AND
CLOSE>MA(CLOSE,5),D*0.91,'买'),COLORYELLOW;
DRAWTEXT(CROSS(D,K)AND
MA(CLOSE,5),D*1.07,'卖'),COLORCYAN;}

绝顶:88,COLORCYAN,LINETHICK1;
中轴:50,COLORLIGRAY;
底部:10,COLORYELLOW;
上方是公式简化副图(图一)。
公式内去掉符号{}就是立体k线及买卖文字(图二)。
选股公式如下:
VAR1:=((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15)))*(100);
VAR2:=SMA(VAR1,5,1);
K:=SMA(VAR2,3,1);
D:=SMA(K,3,1);
选股:BARSLAST(K<=D)>0;
目前属于b浪,后市还有c浪下跌,个人观点仅供参考。

Q5:通达信主力资金进出公式出错 (对不起,条件选股公式主力输出不能超过一个)怎么改?

N1:=10;
N2:=5;
主力资金:=EMA(100*(C-LLV(LOW,30))/(HHV(H,30)-LLV(LOW,30)),3);
爆发:=CROSS(主力资金,80);
TMD:=C-REF(C,1);
金线:=100*EMA(EMA(TMD,N1),N1)/EMA(EMA(ABS(TMD),N1),N1);
银线:=MA(金线,N2);
加仓:=CROSS(金线,-25) OR CROSS(主力资金,65) OR CROSS(金线,0);
XG爆:爆发 OR 加仓;

N1,N2 请自己定义,已测试,下面还有的一公式有未来函数,不宜用于选股。
请采纳。

Q6:请高手把通达信的这条主力资金(开始控盘、控盘、主力出货、主力吸货)指标公式源码改为可在大智慧上使用

VAR2:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);

VAR3:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);

VAR4:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);

VAR5:=(((VAR2 + (2 * VAR3)) + (3 * VAR4)) / 6);

VAR6:=MA(VAR5,3);

开始控盘:(VAR6 <= (0 - 10)),COLOR00AAFF;

STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),3.5,0),COLOR00AAFF;

STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),3.5,0),COLOR0044FF;

STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),2.5,0),COLOR0088FF;

STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),3,0),COLOR00AAFF;

VAR1:=EMA(EMA(CLOSE,3),1);

控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

STICKLINE(控盘<0,控盘,0,3.5,0),COLORFFAA00;

STICKLINE(控盘<0,控盘,0,3.5,0),COLORFF4400;

STICKLINE(控盘<0,控盘,0,2.5,0),COLORFF8800;

STICKLINE(控盘<0,控盘,0,0,0),COLORFFAA00;

主力出货:0,COLORFFAA00;

STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,3.5,0),COLOR000088;

STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,2.5,0),COLOR0000AA;

STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,1.5,0),COLOR0000CC;

STICKLINE(控盘>REF(控盘,3) AND 控盘>0,控盘,0,1,0),COLOR0000EE;

主力吸货:0,COLOR0000FF;

STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,3.5,0),COLOR008800;

STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,2.5,0),COLOR00AA00;

STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,1.5,0),COLOR00CC00;

STICKLINE(控盘<REF(控盘,3) AND 控盘>0,控盘,0,1,0),COLOR00EE00;

STICKLINE("DDX.DDX"<0,0,"DDX.DDX",3.5,0),COLOR008800;

STICKLINE("DDX.DDX"<0,0,"DDX.DDX",2.5,0),COLOR00AA00;

STICKLINE("DDX.DDX"<0,0,"DDX.DDX",1.5,0),COLOR00CC00;

STICKLINE("DDX.DDX"<0,0,"DDX.DDX",1,0),COLOR00EE00;

对倒出货洗盘:0,COLOR00FF00;

黄色底部吸货:0,COLORYELLOW;


DRAWTEXT(CROSS(控盘,0),0-3,'买。追'),COLORFF00FF;

DRAWTEXT(CROSS(0,控盘),0-0,'卖'),COLORGREEN;

DATA:=5;

{多头买入} DRAWICON(ZIG(3,DATA)>REF(ZIG(3,DATA),1)

AND REF(ZIG(3,DATA),1)<=REF(ZIG(3,DATA),2)

AND REF(ZIG(3,DATA),2)<=REF(ZIG(3,DATA),3),L*0.98,7);

{多头卖出} DRAWICON(ZIG(3,DATA)<REF(ZIG(3,DATA),1)

AND REF(ZIG(3,DATA),1)>=REF(ZIG(3,DATA),2)

AND REF(ZIG(3,DATA),2)>=REF(ZIG(3,DATA),3),H*1.02,8);