当前位置:首页 > 问答

通达信金牛出现副图指标公式

我来帮TA回答

请根据这个副图公式给编写一个出现黄色信号的选股公式.通达信用

最后一句改成:
XG:REF(大底,1)>0 AND REF(C,1)<REF(O,1) AND C>O;
股票公式专家团为你解答,希望能帮到你,祝投资顺利。

通达信金牛判势指标源码和机构震仓指标怎么写,如下图效果

TJ:=FILTER(C,239)>0,NODRAW;
TJJ:=SUM(TJ,0),NODRAW;
TJA:=CONST(TJJ),NODRAW;
C1:=CLOSE;
V1:=TIME;
A1:=COUNT(BARSCOUNT(C)=1 AND TIME<102000 ,0 );
T:=IF(V1<130000,(FLOOR(V1/10000)-9.5)*60+(FLOOR(V1/100)-100*FLOOR(V1/10000)),
(FLOOR(V1/10000)-11)*60+(FLOOR(V1/100)-100*FLOOR(V1/10000))),NODRAW;
成交额:=AMOUNT,NODRAW;
VV2:=SUM(AMOUNT,T),NODRAW;
VV3:=VV2/T;
SS:=IF(CAPITAL>150000000,0.3,IF(CAPITAL>20000000,0.5,IF(CAPITAL>10000000,0.8,IF(CAPITAL<200000,5,IF(CAPITAL<1000000,3,
IF(CAPITAL<5000000,1.5,1)))))),NODRAW;
VV5:=(REF(VV3,T-1)/CEILING(REF(VV3,T-1)/CAPITAL *10000+0.1))*SS,NODRAW;
大额线:=IF(REF(VV3,T)=REF(VV3,T-1),VV5,REF(VV3,T)),NODRAW;
起算量:=大额线*100,COLOR00FFFF,NODRAW;
初正1:=IF(T=1 AND DYNAINFO(4)>=DYNAINFO(3),VV2,0);
初负1:=IF(T=1 AND DYNAINFO(4)<DYNAINFO(3),VV2,0);
初正:=SUM(IF(初正1>=大额线 AND T=1,初正1,0),T),NODRAW;
初负:=SUM(IF(初负1>=大额线 AND T=1,初负1,0),T),NODRAW;
初正2:=SUM(初正1,T),NODRAW;
初负2:=SUM(初负1,T),NODRAW;
T00:=IF(C1>REF(C1,1),0.9,-0.9);
T01:=IF(C1<REF(C1,1),-0.9,0.9);
T02:=T00+T01,NODRAW;
TT1:=BARSLAST(CROSS(T02,+1.5)),NODRAW;
TT2:=BARSLAST(CROSS(-1.5,T02)),NODRAW;
TT:=IF(T02=1.8,1,IF(T02=-1.8,-1,0));
正V1:=IF(TT=1 OR (TT=0 AND TT1<TT2),成交额,0),NODRAW;
负V1:=IF(TT=-1 OR (TT=0 AND TT1>TT2),成交额,0),NODRAW;
正负0:=IF(成交额!= 0 AND (正V1=0 AND 负V1=0),成交额,0);
正V0:=IF(正负0!= 0 AND REF(正V1,1)!= 0 ,正负0,0);
负V0:=IF(正负0!= 0 AND REF(负V1,1)!= 0 ,正负0,0);
正V11:=正V1+正V0,NODRAW;
负V11:=负V1+负V0,NODRAW;
正V:=IF(正V11>=大额线,正V11,0);
负V:=IF(负V11>=大额线,负V11,0);
正V2:=IF(正V11<大额线,正V11,0);
负V2:=IF(负V11<大额线,负V11,0);
正总:=IF(TJJ<2,初正,0)+SUM(正V,T),NODRAW,COLOR0000FF;
负总:=IF(TJJ<2,初负,0)+SUM(负V,T),NODRAW,COLOR00FF00;
正总1:=IF(TJJ<2,初正2,0)+SUM(正V11,T),NODRAW,COLOR0000FF;
负总1:=IF(TJJ<2,初负2,0)+SUM(负V11,T),NODRAW,COLOR00FF00;
大差%:(正总-负总)/(正总+负总)*100,COLOR00FF00,NODRAW;
小差%:(正总1-负总1)/(正总1+负总1)*100,COLOR00FF00,NODRAW;
TJJB:=IF(FILTER(T,239)>0 AND TJA>1,REF((正总-负总),T),0),NODRAW;
TJJJB:=SUM(TJJB,0)+IF(TJA>1,(正总-负总),0),NODRAW;
TJJC:=IF(FILTER(T,239)>0 AND TJA>1,REF((正总+负总),T),0),NODRAW;
TJJJC:=SUM(TJJC,0)+IF(TJA>1,(正总+负总),0),NODRAW;
N今:TJJJB/10000,NODRAW;
TJJJB/TJJJC*100,NODRAW;
TJJB2:=IF(FILTER(T,239)>0,REF((正总-负总),T),0),NODRAW;
TJJJB2:=SUM(TJJB2,0),NODRAW;
TJJC2:=IF(FILTER(T,239)>0,REF((正总+负总),T),0),NODRAW;
TJJJC2:=SUM(TJJC2,0),NODRAW;
N昨:TJJJB2/10000,NODRAW;
TJJJB2/TJJJC2*100;
KL:=1;
DRAWBAND(12000*KL,RGB(50,50,50),-5000*KL,DRAWNULL);
Q4:=IF(大差%>=0,12000*KL,0),NODRAW;
Q5:=IF(大差%>=0,-5000*KL,0),NODRAW;
DRAWBAND(Q4,RGB(100,100,100),Q5,RGB(50,50,50));
STICKLINE(CROSS(大差%,0),Q4,Q5,10,0),COLOR777777;
STICKLINE(CROSS(0,大差%),Q4,Q5,10,0),COLOR777777;
DIF:=EMA(CLOSE,20)-EMA(CLOSE,5);
DEA:=EMA(DIF,10);
MACD:=300*(DIF-DEA)*2/EMA(C,30);
VARA:=EMA(REF(CLOSE,1),4);
青山:=(SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100);
绿水:=青山<3.5,COLORDBDBDB;
火红的:=FILTER(MACD<0 AND MACD>REF(MACD,1) AND 青山<20,5);
太阳:=CROSS(青山,90),COLOR00FF00;
DRAWBAND(IF((TJA<2 OR PERIOD!= 0),12000*KL,0),RGB(150,00,100),0,DRAWNULL);
DD:=IF(MACD>=0,MACD,DRAWNULL)*1.5;
STICKLINE(DD AND DD>REF(DD,1),0,DD*80*KL,4,0),COLOR0000FF;
STICKLINE(DD AND DD<REF(DD,1),0,DD*80*KL,3,1),COLOR0000FF;
IF(TJA<2,(青山-25)*150*KL,DRAWNULL),COLOR5BE000,LINETHICK6;
DRAWBAND(IF((TJA<2 OR PERIOD!= 0) AND (青山-25)*1.5>0,(青山-25)*150*KL,0),RGB(00,200,50),0,DRAWNULL);
DRAWBAND(0,RGB(00,180,120),IF((TJA<2 OR PERIOD!= 0),-5000*KL,0),DRAWNULL);
ZJ2:=V/((H-L)*2-ABS(C-O));
ZJ3:=IF(C>O,ZJ2*(H-L),IF(C<O,ZJ2*(H-O+(C-L)),V/2))+IF(C>O,0-ZJ2*(H-C+(O-L)),IF(C<O,0-ZJ2*(H-L),0-V/2));
攻击流量:=ZJ3/20/1.15;
ZJ5:=攻击流量*0.55+REF(攻击流量,1)*0.33+REF(攻击流量,2)*0.22;
日流量:=EMA(ZJ5,3);
STICKLINE(C>0 AND 日流量>=0,日流量,0,2,0),COLORFF38FF;
STICKLINE(C>0 AND 日流量<=0,日流量,0,2,0),COLORFA3300;
AR1:=LLV(LOW,10);
AR2:=HHV(H,25);
AR3:=EMA((C-AR1)/(AR2-AR1)*4,4);
红红的天:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)
-LLV(LOW,27))*100,5,1),3,1),LINETHICK0;
IF((TJA<2 OR PERIOD!= 0) AND CROSS(红红的天,2),7000*KL,-5000*KL),COLOR0000FF;
IF(红红的天>10,-5000*KL,DRAWNULL),CIRCLEDOT,COLORGREEN;
IF(红红的天<=10,-5000*KL,DRAWNULL),CIRCLEDOT,COLOR0000CC;
N:=IF(TJA<2 AND PERIOD=0,20,6);
L1:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*200-60;
有心就有:IF((TJA<2 OR PERIOD!= 0) AND CROSS(红红的天,2),7000*KL,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF77FF;
好运!:IF((TJA<2 OR PERIOD!= 0) AND CROSS(红红的天,2),7000*KL,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;
STICKLINE(CROSS(3.5,AR3),10000*KL,12000*KL,2,0), COLOR00FFFF,LINETHICK2;
STICKLINE(CROSS(AR3,0.3),-5000*KL,-3000*KL,2,0),COLORRED,LINETHICK2;
DRAWTEXT(CROSS( 0,MACD)AND 青山>75 OR 太阳,9800*KL,'ヲ'),COLORDBDBDB;
DRAWTEXT(绿水,-3000*KL,'ャ'),COLORDBDBDB;
DRAWTEXT(绿水,-3000*KL,'︼'),COLOR688EC1;
IF(PERIOD=0,2500,DRAWNULL),COLORAAAAAA,LINETHICK2;
{盘龙驸凤}
望喜:IF(PERIOD=0,小差%*100+2500,DRAWNULL),COLOR000000,LINETHICK1;
IF(PERIOD=0 AND TJA>1,小差%*100+2500,DRAWNULL),COLORFFFF00;
盘龙:IF(PERIOD=0,大差%*100+2500,DRAWNULL),COLOR00FFFF,LINETHICK2;
STICKLINE(PERIOD=0 AND FILTER(T,239)>0,12000*KL,-5000*KL,1,0),COLORWHITE;
A7:=C-REF(C,1);
A8:=IF(((TJA<2 OR PERIOD!= 0) OR PERIOD!= 0),5000*EMA(EMA(A7,11),11)/EMA(EMA(ABS(A7),11),11),DRAWNULL),LINETHICK2;
SHORT:=3; LONG:=19;
RMA:=EMA(CLOSE,SHORT);
NMA:=EMA(CLOSE,LONG);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1),LLV(L,BARSLAST(CROSS(NMA,RMA))+1),H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),HHV(H,BARSLAST(CROSS(RMA,NMA))+1),0);
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),HHV(H,BARSLAST(CROSS(RMA,NMA))+1),L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1),LLV(L,BARSLAST(CROSS(NMA,RMA))+1),0);
买进:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
卖出:=(HHV(A8,2)=HHV(A8,7) OR A8=HHV(A8,2)) AND DOWN>REF(UP,1);
DRAWICON(买进=0,A8*1.1,1);
DRAWICON(买进=1,A8,23);
RV:=((CLOSE-LLV(LOW,5))/(HHV(HIGH,27)-LLV(LOW,27))*200-60)*100*KL;
VAR4:=SMA(RV,3,1);
VAR5:=SMA(VAR4,3,1);
龙K:IF(((TJA<2 OR PERIOD!= 0) OR PERIOD!= 0),SMA(L1,3,1)*100*KL,DRAWNULL),COLORRED;
凤D:IF(((TJA<2 OR PERIOD!= 0) OR PERIOD!= 0),SMA(龙K,3,1),DRAWNULL),COLORBBFFBB;
N1:=7;
LC:=REF(CLOSE,1);
X:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*1000,COLORMAGENTA;
牛相:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1);
TJ1:=X=牛相;
TJ2:=X<REF(X,1);
DRAWICON(TJ1 AND TJ2,X,1);
DRAWTEXT(TJ1 AND TJ2,X,'买')COLORRED;
VAR1R:=(HIGH+LOW+CLOSE*2)/4;
VAR2R:=EMA(VAR1R,21);
VAR3R:=STD(VAR1R,21);
VAR4R:=((VAR1R-VAR2R)/VAR3R*100+200)/4;
VAR5R:=(EMA(VAR4R,5)-25)*1.56;
AK:=EMA(VAR5R,2)*1.22;
AD1:=EMA(AK,2);
拐点:=CROSS(AD1,AK);
DRAWTEXT(拐点,X,'变盘');
VAR6R:=((C+2*L)/3-LLV(L,8))/(HHV(H,8)-LLV(L,8))*100;
VAR7R:=SMA(VAR6R,2,1);
DRAWTEXT(X>50 AND X<=80 AND CROSS(X,VAR7R),X,'追'),COLORYELLOW;
DRAWTEXT(CROSS(X,70) AND VAR7R<15,X,'底'),COLORRED;
DRAWTEXT(CROSS(X,85) AND VAR7R<10,X,'涨'),COLORMAGENTA;
DRAWTEXT(VAR7R<11 AND VAR7R>REF(VAR7R,1),VAR7R,'涨'),COLORRED;
DRAWTEXT(CROSS(X,70) AND VAR7R<20,X,'底'),COLORRED;
DRAWTEXT(ISLASTBAR,X,' 金牛判势'),COLORRED;

通达信 大盘指数作副图 指标编程代码!!

{上证指数K线副图指标}
DRAWKLINE("999999$H","999999$O","999999$L","999999$C");
上证:"999999$C",COLORWHITE,NODRAW;
_±:"999999$C"-REF("999999$C",1),COLORLIGRAY,NODRAW;
五:MA("999999$C",5),COLORWHITE;
十:MA("999999$C",10),COLORYELLOW;
二十:MA("999999$C",20),COLORMAGENTA;
六十:MA("999999$C",60),COLORGREEN;
股票公式专家团为你解答,希望能帮到你,祝投资顺利。

通达信主图指标公式在副图显示

进入公式管理器
在右上角点击主图叠加改为副图叠加就可以了
或者直接点主图
进入修改指标模式
变更主图叠加为副图叠加就是了

请高手把通达信里的布局主升浪指标改成选股公式

P13:=MA(C,13);
VAR1:=HHV(H,9)-LLV(L,9);
VAR2:=HHV(H,9)-C;
截图没有意义,要文字说明。没有指定选股条件,无法编写。

通达信超级主升浪选股公式怎样导入

通达信公式导入
打开软件以后,注意左上角的工具,点开。
下半部分有个公示系统,鼠标放在上面以后,出现公式管理器,点开。
管理器的界面右侧功能栏,有导入功能,点它,然后按步骤做就可以了。
  • 财惠网
  • 炒股配资网
  • 巨财网
  • 黄金喊单
  • 原油直播室
  • 原油期货网
  • 原油期货
  • 期货直播间
  • 黄金喊单
  • 外盘期货喊单
  • 期货直播室
  • 恒指喊单直播室
  • 期货直播室
  • 薛城财经
  • 国际期货喊单
  • 助腾财经
  • 黄金喊单
  • 中银网
  • 恒指期货直播
  • 美原油直播室
  • 黄金喊单
  • 金融知识科普网
  • 亿森财经
  • >凯贝股票网
  • 财姐网
  • >东台网
  • 广东炒股网